C++项目在不同版本vs下同时开发关于静态库等兼容性问题

  • 2019-08-21
  • 程序简版
  • 公开
简介由于不同vs版本使用的平台工具集版本号不同,通过在属性页 - 配置属性 - 常规 - 平台工具集 填上$(DefaultPlatformToolset) ,大概意思就是使用默认工具集版本号,而这个版本号等于当前IDE的版本号,比如2012就是v110。可以避免在切换vs开发环境时手动选择平台工具集。关于自适应平台工具集:https://zhuanlan.zhihu.com/p/61518123 静态库的问题。虽然VS2015~2019 ABI兼容。但是由于VS默认开启全程序优化(

由于不同vs版本使用的平台工具集版本号不同,通过在属性页 - 配置属性 - 常规 - 平台工具集 填上$(DefaultPlatformToolset) ,大概意思就是使用默认工具集版本号,而这个版本号等于当前IDE的版本号,比如2012就是v110。可以避免在切换vs开发环境时手动选择平台工具集。关于自适应平台工具集:https://zhuanlan.zhihu.com/p/61518123


静态库的问题。虽然VS2015~2019 ABI兼容。但是由于VS默认开启全程序优化(/GL), 如果你没关闭,这将导致编译出来的静态库(obj组成的那种),兼容性大大降低。为了保证lib文件的通用性,建议所有静态库工程都关闭全程序优化(/GL)。在属性页 - 配置属性 - C/C++ - 优化 - 全程序优化 调整为 否。

  1. 使用静态库的一个原则“向下兼容”,显然的,不可能用一个vs2019编译出来的静态库拿到vs2012中使用(虽然有些时候这样用没什么问题)。只能由高版本的开发环境去兼容低版本的静态库。
  2. 关于符号集的问题(通过导入legacy_stdio_definitions.lib以及增加自定义的转换函数来解决)。
  3. 在程序中可以判断是当前开发平台的_MSC_VER来决定是否来做向下兼容。关于_MSC_VER可以查看百度百科的介绍

#pragma once

#if _MSC_VER>=1900
	#pragma comment(lib, "legacy_stdio_definitions.lib")
	#include "stdio.h" 
	_ACRTIMP_ALT FILE * __cdecl __acrt_iob_func(unsigned);
	#ifdef __cplusplus 
	extern "C"
	#endif 
	FILE* __cdecl __iob_func(unsigned i) {
		return __acrt_iob_func(i);
	}
#endif /* _MSC_VER>=1900 */

#if _MSC_VER>=1900
	#ifdef _DEBUG
		#pragma comment(lib, "log4cplusSUD_10.lib")
	#else
		#pragma comment(lib, "log4cplusSU_10.lib")
	#endif
#else
	#ifdef _DEBUG
		#pragma comment(lib, "log4cplusSUD_7.lib")
	#else
		#pragma comment(lib, "log4cplusSU_7.lib")
	#endif
#endif /* _MSC_VER>=1900 */

当然,多个vs版本编译出的不同版本的静态库也可以用该方法分别引入,这样就不用处理符号集的问题了。